Tuesday, January 12, 2016

You will not find better service from Amateur radio manufacturer.

My Elecraft K3 stopped working on Tuesday.

I've emailed to Garry at Elecraft and got the answer within a few hours. Solution and spare parts for mere USD 12-00.

Cant beat that.

73
P

Below the email exchange:

Thanks again.  I'm more than very pleased with the service

73
Patrick

Please read the emails from bottom up.

On 13/01/2016 10:18, Gary Surrency wrote:
> Thank you Patrick. I will ask Madeline to reply to you with the postage cost.
>
> When removing the old connectors, either pull off the plastic carrier or clip the pins so you only have to heat and remove one at a time. Then remove the solder from the plated through holes.
>
> Be sure the new connectors are installed on the correct side of the RF PCB. Solder only 1 or 2 pins initially and trial fit the FP and RF boards together, then  solder the rest of the pins.
>
> --
> 73, Gary AB7MY
>
> =========
> support@elecraft.com
> Elecraft Technical Support

> On 1/12/2016 2:57 PM, Patrick Novak wrote:
>> Thanks Garry yet again.
>>
>> On a second thought I may ask you to send me the gold connectors please.  I have vague recollection that the pins were not gold plated when I was assembling the rig.  I think that you guys brought in the gold much later.
>>
>> I insist paying for the connectors or at least the postage... Please let me know how can I pay (or if you still have my credit card data).
>>
>> Thanks again
>>
>> 73
>> Patrick VK2PN
>>
>> On 13/01/2016 08:31, Gary Surrency wrote:
>>> OK Patrick. Good luck and let me know if we need to send the gold connectors.
>>>
>>> --
>>> 73, Gary AB7MY
>>>
>>> =========
>>> support@elecraft.com
>>> Elecraft Technical Support
>>>
>>> On 1/12/2016 12:27 PM, Patrick Novak wrote:
>>>> Hi Garry and many thanks for the advice. Will try to do it when we return.
>>>>
>>>> cheers
>>>> 73
>>>> Patrick VK2PN
>>>>
>>>> On 13/01/2016 02:55, Gary Surrency wrote:
>>>>> Hi Patrick,
>>>>>
>>>>> Poor connections on the RF board to front panel board pin connectors can those errors.
>>>>>
>>>>> Clean them and use De-Oxit, or replace P30, P35 on the RF board with gold plated connectors (free from us on request) if the original ones are tin plated.
>>>>>
>>>>>
>>>>> --
>>>>> 73, Gary AB7MY
>>>>>
>>>>> =========
>>>>> support@elecraft.com
>>>>> Elecraft Technical Support
>>>>>
>>>>> On 1/12/2016 12:25 AM, Patrick Novak wrote:
>>>>>> Hi guys,
>>>>>>
>>>>>> This morning my K3 (Nr: 3234 kit) displayed ERR BP1 and after pressing a key I'm getting IF1 DP1 LPF XV3 BP2 AT3 PA1 etc.
>>>>>>
>>>>>> Reloading the firmware did not make any difference. Yesterday the radio was on most of the day (hot day in Sydney), since I was waiting for the K5P to appear.
>>>>>>
>>>>>> We (the boss and I) are leaving Sydney tomorrow and will not be home for at least three weeks (the grey nomad caravan syndrome). I'm taking my KX3 + amp with me so there is no tragedy of not being to operate.
>>>>>>
>>>>>> Can you please give me a hint as what is happening?  Is it serious or is it just poor contact somewhere (says he with hope).
>>>>>>
>>>>>> There is no urgency since I can't do anything before we return.
>>>>>>
>>>>>> Thanks guys/gals
>>>>>>
>>>>>> 73
>>>>>> Patrick VK2PN

The Northern Corridor Radio Group VK6ANC

As a part of our big trip around Australia in four and a half months in a little caravan I have taken the opportunity to visit one of the be...